Интерфейс TextEditor

Материал из wiki.appsalutecreator.com
Перейти к: навигация, поиск

Ico text.pngРедактор текстов

Ico text.png Text Editor - хранилище всех текстовых ресурсов (надписей) на различных языках.
Аналогично графике и звукам при помощи мышки они перетаскиваются в соответствующие свойства объектов, находящихся в Scene Editor.

См. также
Урок 6

Окно редактора имеет следующий вид:

Text baze main.jpg

Общие свойства и действия с текстом

После любых действий в текстовом редакторе необходимо обновить текстовую базу в Редакторе сцен!

  • элемент текстовой базы - строка текста, которая может хранить в себе несколько различных фраз,записанных в разные поля
  • фраза персонажа на разных языках записывается в один элемент текстовой базы
  • в текстовой базе может храниться voice
  • элемент текстовой базы может хранить в себе несколько иконок, для которых можно выбрать одну из 4-х категорий (mainPicture, icon1, icon2,icon3)
  • каждому элементу текстовой базы присваивается уникальный номер.
  • при добавлении элемента - присваивается следующий по порядку уникальный номер
  • при экспорте экранов в текущий проект элементы текстовой базы добавляются автоматически в базу текущего проекта и присваиваются им следующие по порядку уникальные номера
  • может существовать несколько элементов с одинаковыми именами
  • текст может быть автоматически добавлен в текущий проект или добавлен из другой текстовой базы
  • элемент текстовой базы может быть удален, модифицирован, категоризирован

Кнопки быстрого запуска

Вверху окна приложения расположены кнопки общего меню:

  • 00 6.png — команда создать Новый файл;
  • 00 7.png — команда открыть уже созданный проект;
  • 00 8.png — сохранить изменения в файле;
  • 00 18.png — создать новую папку в корневой базе;
  • New record.jpg — добавить новую текстовую запись;
  • Add new rec fr.jpg — добавить новую текстовую запись из базы ресурсов;
  • Add url.jpg — добавить новую url запись;
  • 00 19.png — удалить текстовую запись;
  • Text base find.png — найти необходимую текстовую запись в текстовой базе.

Меню редактора

1. Если нажать в меню кнопку File, выпадет список команд, с помощью которых можно создать новый или загрузить уже созданный файл, сохранить файл с указанием места сохранения и т.д.
2.Для импорта фраз на другом языке необходимо воспользоваться Функцией Импортировать меню File и выбрать .xml-файл с текстом и выбрать язык
3. Если нажать в меню кнопку Resource, выпадет список команд:

  • Open Resource - позволяет создать базу по ранее подготовленной графической базе ресурсов с точным совпадением структуры и названием папок и файлов. Используется для Hidden Objects;
  • Choose Resource File - позволяет подгрузить базу графических ресурсов для перетаскивания изображений из ResourcesEditor на иконку;
  • Choose Categories Config - помогает классифицировать текстовые файлы по категориям.

00 51.PNG 00 52.PNG


Создание и заполнение текстовой базы проекта

Текстовая база не создается автоматически при создании проекта.
Для создания и заполнения текстовой базы:
1. Заходите в пункт меню file -> New. Появляется пустая база ресурсов, по умолчанию названная Untitled.
2. Слева в дереве текстовых объектов кликаем правой кнопкой мыши и выбираем Add record. Каждый раз при добавлении новой текстовой записи редактор просит нас написать ее имя. Это имя можно будет изменить в любой момент. Запишем имя arrow_If_down.
3. Выделить запись и в окне приложения TextEditor справа в столбце Word запишем слово, в столбце Sentence1,Sentence2 - указать подсказку для текстовой записи, в столбце voice - подключить звуковой файл для текстовой записи из ResourcesEditor.
00 54.PNG

Необходимо обязательно сохранять любые изменения с текстом в редакторе TextEditor.
Для вызова текстового редактора можно воспользоваться меню Инструменты -> Редактор текстов, либо кнопкой быстрого запуска Text base.png.

Замечание. Букву Ё заменяем на Е

Импорт текстовой базы

На данный момент у импорта есть 2 режима:

  • слияние текстовых баз - флаг "Import as new record" выключен, перезаписывает записи из базы импортированными;
  • добавление новых записей - флаг "Import as new record" включен, добавляет импортированные записи в базу.

TextsEditor import menu.jpg

Зелеными шариками TextsEditor green sphere.png обозначены языки, используемые в проекте (выбранные в Project > Properties > Selected languages...)

Серыми шариками TextsEditor gray sphere.png обозначены языки, которые на данный момент не используются в проекте. Вы можете их импортировать, но для работы с ними их нужно будет включить.

Экспорт текстовой базы

Существует два варианта экспорта текстовой базы:

  • Export into txt . . . - в файл с расширением .csv (текстовый файл)
  • Export into xml . . . - в файл с расширением .xml (текстовая база)

Само окно экспорта аналогично окну импорта:

TextsEditor export menu.jpg

  • Экспорт в xml генерирует файл, идентичный файлу текстовой базы, но лишь с выбранными в окне языками;
  • При экспорте в csv создается файл такой структуры:

Text baza export 5.jpg

Экспортироваться будут лишь те языки, которые были выбраны в данном окне, вне зависимости от их наличия в базе. Пустые поля и языки экспортированы не будут.

При выборе флага "Export empty lines" будут экспортированы все пустые поля и языки, что очень полезно для перевода базы.

Добавление иконок в текстовый элемент

Необходимость добавления изображения в текстовый элемент, может возникнуть, например, при формировании элементов hiddenObject, или при работе с элементами economics. Изображение перетаскивается в текстовый элемент из редактора ресурсов мышкой. Но, в случае необходимости создать множество элементов за один раз, есть более эффективный способ:

  • На панели с кнопками быстрого запуска нажимаем Add new text records from resource....

Add new rec from.jpg

  • Открылось окошко choose resource file в нем следует выбрать необходимый sirx файл.

Choose resource file.jpg

  • В открывшемся дереве ресурсов выбираем нужную папку

Tree resources.jpg

  • Из отмеченной папки файлы преобразуются в текстовые элементы, содержащие строку word и соответствующее изображение. Причем добавятся они в текстовый редактор в папку, которая создастся в соответствии с папкой, содержащей эти иконки в редакторе ресурсов.

Если вдруг так получилось, что к текстовой записи подвязан ресурс которого больше нет в базе ресурсов -- он будет обозначен как "INVALID RESOURCE":

TextsEditor invalid image.JPG

Поиск записи в текстовой базе

Окно поиска текстовой записи активируется при нажатии кнопки быстрого запуска Text base find.png.
Text base find wind.jpg
Поиск проходит по непосредственно содержимому текстового поля.
Поиск по дереву базы может проходить сверху вниз и снизу вверх, если выбрать один из пунктов группы Find direction:

  • down - искать сверху вниз;
  • up - искать снизу вверх.

Для оптимизации процесса поиска можно выбрать в группе Find mode один из следующих пунктов:

  • in the whole tree - искать во всем дереве;
  • from the current item - искать от текущего элемента.

Строка, которая вводится в строку поиска может быть подстрокой интересующей нас записи либо же полностью с ней совпадать. Это можно регулировать с помощью пункта Only the whole text.